All-in-one SEO packの2.2はインストールするな!

Author:

ダッシュボードを開くと、プラグイン更新通知があった。
いつものようにアップデートして、ブログを書こうとウィンドウを開く。

あれ?
タグ挿入ボタンが無いぞ??
開発者ツールを開いてみると、赤文字で
「aioseop_data is not defined」と。

なんかバグってるー!!

どうやら先程アップデートしたプラグインが悪さしてそうだ。
何入れたっけ。
all-in-one SEO packだ。

All-in-one SEO packのPlugin Forumを覗いてみると、同様の報告が多数。
バージョン戻すことにしよう。

DBに更新かかってないかちょっと心配だけど
ファイルを直に戻すことにする。


ってことでまずはDevelopper’s pageから一つ前のバージョン、2.1.7をダウンロード。

解凍する。

んでFTPでwordpressのサーバーに入って、
wp-content/plugins/all-in-one-seo-packのフォルダを丸ごと削除。
そしてダウンロードした旧バージョンのファイルをアップロード。
これで完了。


投稿画面からボタンが復活しているのを確認。OKっぽい。
当然更新通知がまた出てくるけど放置。
何かのタイミングで一括更新したらまた同様の現象になるので気をつけましょう。
たぶんそんなに時間かからず修正パッチが出るでしょうけど。


FTPって何?って人は周りのパソコン詳しい人に聞きましょう。
こういう事があるからWordPress使いはITメンターが必須になるのですよね。

結局WordPressはDBをいじられない限り、
本体もプラグインも好きなバージョンを入れなおすことができるのがメリットかも。
最初だけ警告出るけど本体のバージョンダウンとかやったことあるし。
インストーラー式のjoomlaとかだとこんなに上手くはいかないんだろうなあ。


ってことで、All-in-one SEO packの2.2はインストールしないように。
してしまったらJSのエラーで投稿画面が不自由になってしまいます。

【追記】
2.2.1がリリースされたみたいなのでもうアップデートしても大丈夫ですよー

Facebook にシェア
Pocket